Just a quick heads up as this happened to me today, and I googled for a bit and found a solution I thought I'd post here.

If you are running Vista or 7, and are getting errors based on Steam being forced by Windows to run in XP Compatibility mode, or are being booted from the servers for a failure to connect to VAC secure network, try this out:

Run "Regedit"

Follow this:

HKEY_CURRENT_USER\Software\Microsoft\Windows NT\CurrentVersion\AppCompatFlags\Layers

If Steam.exe is in there, delete the file.

If that doesn't work, follow:

HKEY_LOCAL_MACHINE\Software\Microsoft\Windows NT\CurrentVersion\AppCompatFlags\Layers

And again, find and delete the steam.exe file.

Further to this, if those dont work, follow:

HKEY_CURRENT_USER\Software\Microsoft\Windows NT\CurrentVersion\AppCompatFlags\Compatibility Assistant\Persisted

Again, look for the Steam.exe file and delete it.

Basically, all this does is stops Windows from automatically setting your compatibility for Steam, which it shouldn't be doing anyways. This is a problem for some reason with the new Steam, so it just started happening.

I had to delete two to get mine to work flawlessly again. It's an annoying problem, so if it starts happening to you, here's the fix.